Figma.com experiencing outage
Incident Report for Figma
Resolved
We identified the issue and all systems should be back to normal. We will be monitoring but any open documents in the meantime should automatically reconnect.
Posted over 2 years ago. Mar 21, 2017 - 07:15 UTC
Investigating
We will update shortly
Posted over 2 years ago. Mar 21, 2017 - 06:41 UTC