Service disruption for UK customers
Incident Report for Figma
Resolved
We’ve identified the root cause of service disruption for some UK customers. Figma should be fully operational again for those regional users. If you continue to have problems connecting to Figma, email support@figma.com.
Posted 29 days ago. Aug 22, 2019 - 09:56 UTC
Update
We are continuing to investigate the cause of service disruption for some UK customers. A number of users have reported that restarting their browser has resolved this situation and we ask that, after you try this, if you continue to have problems connecting to Figma that you contact us using the in-app Help widget (‘?’), or email support@figma.com so that we can investigate further.
Posted 29 days ago. Aug 22, 2019 - 09:37 UTC
Investigating
We are currently investigating reports of service disruption for some UK customers. We suspect this is a broader internet connectivity issue between one or more ISPs in that region and our servers.
Posted 29 days ago. Aug 22, 2019 - 09:04 UTC