Email service is experiencing delays
Incident Report for Figma
Resolved
Emails are no longer experiencing significant delays.
Posted almost 3 years ago. Sep 28, 2016 - 19:25 UTC
Identified
We're experiencing some delays with our email service, currently between 5-40 minutes. We are working with them to eliminate this and prevent further issues. Please contact support at support@figma.com if we can help you in any way.
Posted almost 3 years ago. Sep 28, 2016 - 18:49 UTC