Figma Make Service Disruption

Incident Report for Figma

Resolved

This incident has been resolved.
Posted Apr 10, 2026 - 16:00 UTC

Monitoring

Some users on certain VPN providers may have experienced difficulty loading Figma Make files and published Sites. The issue has been resolved. We are monitoring to confirm full recovery.
Posted Apr 09, 2026 - 22:33 UTC

Investigating

We are investigating an issue some users are experiencing while loading Figma Make files or published Sites.
Posted Apr 09, 2026 - 19:00 UTC