Service disruption

Incident Report for Figma

Resolved

This incident has been resolved.
Posted Nov 28, 2024 - 03:50 UTC

Monitoring

The issue has been identified and fixed.
Posted Nov 28, 2024 - 01:43 UTC

Investigating

We are investigating an issue where some customers are unable to load files through the file browser.
Posted Nov 28, 2024 - 00:34 UTC