Service disruption

Incident Report for Figma

Resolved

We've mitigated the impact of this issue.
Posted Jun 12, 2023 - 23:21 UTC

Investigating

We are investigating an issue that is causing intermittent loading issues for some users
Posted Jun 12, 2023 - 22:36 UTC
This incident affected: Real-time collaboration server and APIs & Web Application.