Figma Publishing Disruption

Incident Report for Figma

Resolved

This incident has been resolved.
Posted Jun 12, 2025 - 23:03 UTC

Monitoring

We are monitoring recovery as access to previously published Makes and Sites become available.
Posted Jun 12, 2025 - 19:44 UTC

Investigating

We’re investigating reports that previously published Sites and Makes are inaccessible and new publish attempts are failing.
Posted Jun 12, 2025 - 18:57 UTC