Service Disruption
Incident Report for Figma
Resolved
This incident has been resolved
Posted Sep 25, 2023 - 15:29 UTC
Monitoring
A fix has been implemented and we're monitoring the result.
Posted Sep 25, 2023 - 14:51 UTC
Identified
The issue has been identified and we're working on a fix.
Posted Sep 25, 2023 - 14:21 UTC
Investigating
We are currently investigating an issue where users may have issues loading Figma or saving files
Posted Sep 25, 2023 - 12:46 UTC
This incident affected: APIs & Web Application.