Degraded performance with images and team libraries
Incident Report for Figma
Resolved
This incident has been resolved. If you're still experiencing issues please contact our support team via the help widget or email support@figma.com
Posted Mar 18, 2020 - 21:47 UTC
Monitoring
We've taken steps to address the incident and will continue to monitor the situation closely to ensure there are no recurring issues.
Posted Mar 18, 2020 - 16:53 UTC
Investigating
We’re currently investigating an issue where some users are unable to upload images or make changes to their team libraries such as publishing.
Posted Mar 18, 2020 - 15:20 UTC
This incident affected: APIs & Web Application.