Figma Make Publishing Disruption

Incident Report for Figma

Monitoring

A fix has been implemented and we're monitoring the results.
Posted Mar 12, 2026 - 15:19 UTC

Identified

We have identified the issue that is preventing some users from previewing and publishing Figma Make files.
We are now working to fix it.
Posted Mar 12, 2026 - 14:43 UTC

Investigating

We are investigating an issue loading previews and publishing Figma Make files.
Posted Mar 12, 2026 - 14:00 UTC