Figma service disruption

Incident Report for Figma

Resolved

From 19:38 UTC to 4:10 UTC, Figma was degraded or unavailable due to failures in AWS and other dependencies. We've completed all mitigations and have been monitoring the situation for a few hours now without issues. We haven't seen any abnormal issues since our 4:10 UTC update, so we are marking the incident resolved. We will continue to monitor closely through the night.
Posted Oct 21, 2025 - 06:53 UTC

Update

We continue to make significant progress recovering our systems. Error rates are still elevated for some users as we continue to apply our mitigations to all impacted servers. We will post another update in an hour or sooner if we recover fully before then.
Posted Oct 21, 2025 - 04:10 UTC

Monitoring

We have made significant progress, but error rates are still elevated for some users as we work to apply our mitigations to all impacted servers. We will post another update in an hour or sooner if we recover fully before then.
Posted Oct 21, 2025 - 02:30 UTC

Update

We are currently working to mitigate issues where Figma Services are degraded or unavailable because of previous impact from AWS and other dependencies. Although we have restored some systems we have not fully recovered. We will update when we see further significant recovery or in another hour.
Posted Oct 21, 2025 - 00:41 UTC

Update

We are currently working to mitigate issues where Figma Services are degraded or unavailable because of previous impact from AWS and other dependencies. Although we have restored some systems we have not fully recovered. We will update when we see further significant recovery or in another hour.
Posted Oct 21, 2025 - 00:35 UTC

Update

We are currently working to mitigate issues where Figma Services are degraded or unavailable because of failures with AWS and other dependencies. We have recovered some Figma systems and are working to recover the rest. We will update when we see significant recovery or in another hour.
Posted Oct 20, 2025 - 22:53 UTC

Identified

We are currently working to mitigate issues where Figma Services are degraded or unavailable because of failures with AWS and other dependencies. We will update in the next hour.
Posted Oct 20, 2025 - 21:24 UTC

Investigating

We are currently investigating an issue where Figma Services are degraded or unavailable because of failures with AWS and other dependencies.
Posted Oct 20, 2025 - 19:55 UTC
This incident affected: Real-time collaboration server and APIs & Web Application.