Reports of service disruption
Incident Report for Figma
Resolved
The incident resulted from increased global network congestion. We were able to resolve the issue by deploying a CDN for users to connect to in Europe and Asia.
Posted Apr 09, 2020 - 22:54 UTC
Investigating
We are currently investigating reports of service disruption for Users in some areas of Europe and Asia. We suspect this is a broader internet connectivity issue between one or more ISPs and our servers.
Posted Apr 01, 2020 - 07:59 UTC