Service disruption
Incident Report for Figma
Resolved
The incident has been resolved.
Posted Mar 27, 2021 - 17:16 UTC
Identified
Figma files are not loading. We're aware of the root cause and we working to resolve it.
Posted Mar 27, 2021 - 17:12 UTC