Some billing-related operations unavailable
Incident Report for Figma
Resolved
This incident has been resolved.
Posted 2 months ago. Jul 10, 2019 - 23:16 UTC
Investigating
Due to issues originating with our payments service provider, some operations on the Figma website are currently unavailable, such as viewing past invoices or upgrading a team to Figma Professional. We're monitoring the situation and will continue to update this space as we learn more.
Posted 2 months ago. Jul 10, 2019 - 22:35 UTC
This incident affected: APIs & Web Application.