Service disruption
Incident Report for Figma
Postmortem

One of our servers that routes requests experienced a hardware failure, causing a small percentage of requests to fail for 8 minutes. We were alerted to the issue by our monitoring systems as it happened, and were able to fail over to a standby server. In response to this incident, we have already deployed improvements to our automated health checks so that we can recover within seconds vs. minutes if this happens again.

Posted Jun 19, 2020 - 20:16 UTC

Resolved
This incident has been resolved.
Posted Jun 17, 2020 - 18:10 UTC
Update
We are continuing to monitor for any further issues.
Posted Jun 17, 2020 - 18:00 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jun 17, 2020 - 17:56 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Jun 17, 2020 - 17:55 UTC
Update
We are continuing to investigate this issue.
Posted Jun 17, 2020 - 17:52 UTC
Investigating
We are currently investigating this issue.
Posted Jun 17, 2020 - 17:50 UTC
This incident affected: APIs & Web Application.